What’s Vulnerable › Vulnerabilities
CVE-2026-75973: Apache Tomcat: Cross-context authentication mix-up with Jakarta Authentication configured
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-23
- Weakness: CWE-287
Description
Improper Authentication vulnerability in Apache Tomcat. When Jakarta Authentication was configured with SimpleAuthConfigProvider as the default provider and multiple web application used that provider, the realm for the first web application to authenticate a request would be used for all web applications. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.25, from 10.1.0-M1 through 10.1.59, from 9.0.0.M4 through 9.0.121. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.26, 10.1.60, 9.0.122, which fixes the issue.
Affected products
- Apache Tomcat: from 11.0.0-M1 through 11.0.25; from 10.1.0-M1 through 10.1.59; from 9.0.0.M4 through 9.0.121; from 8.5.0 through 8.5.100
References
- https://lists.apache.org/thread/njjcdkkzqyzx4n3ffc4ffjmyh5mpl1gr
- http://www.openwall.com/lists/oss-security/2026/09/23/20
Get alerted when CVE-2026-75973 or the next vulnerability affects your stack