What’s Vulnerable › Vulnerabilities
CVE-2026-75991: Illustrator | Improper Input Validation (CWE-20)
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-18
- Weakness: CWE-20
Description
Illustrator is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. Exploitation of this issue requires user interaction in that a victim must open a malicious file. Scope is changed.
Affected products
- Adobe Illustrator: from 29.0 before 29.8.11; from 30.0 before 30.8 — fixed in 29.8.11, 30.8
How to fix
Upgrade to a fixed version: Adobe Illustrator 29.8.11, 30.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-75991 or the next vulnerability affects your stack