What’s Vulnerable › Vulnerabilities
CVE-2026-76212: phpMyFAQ before 4.1.7 LIKE Wildcard Injection via PostgreSQL
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-19 · updated 2026-09-01
- Weakness: CWE-88
Description
phpMyFAQ before 4.1.7, when configured to use PostgreSQL via the native pgsql PHP extension, declares an incorrect LIKE ESCAPE character ('=') in the Search/Database/Pgsql.php backend while escapeLikeWildcards() escapes user input with the '|' prefix. As a result, wildcard escaping is a no-op and user-supplied % and _ characters remain active LIKE wildcards. An unauthenticated attacker can submit such characters in the public FAQ search form to force maximally broad pattern matches and expensive sequential scans, resulting in a denial of service. The PDO PostgreSQL backend is not affected, and quotes remain escaped so this does not enable quote-breaking SQL injection or data exfiltration.
Affected products
- thorsten phpMyFAQ: before 4.1.7 — fixed in 4.1.7
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-5hx6-c293-588h
- https://www.vulncheck.com/advisories/phpmyfaq-before-like-wildcard-injection-via-postgresql
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-5hx6-c293-588h
Get alerted when CVE-2026-76212 or the next vulnerability affects your stack