What’s Vulnerable › Vulnerabilities
CVE-2026-76213: phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-19 · updated 2026-09-01
- Weakness: CWE-307
Description
phpMyFAQ before 4.1.7 contains a brute-force vulnerability in the two-factor authentication step where the failure counter is session-scoped and reset on each successful password re-authentication. Attackers with a valid password can bypass the five-attempt limit by obtaining a fresh session cookie and repeatedly re-authenticating to reset the counter, enabling unbounded TOTP code guessing.
Affected products
- thorsten phpMyFAQ: before 4.1.7 — fixed in 4.1.7
How to fix
Upgrade to a fixed version: thorsten phpMyFAQ 4.1.7. Check the vendor advisory for mitigations.
References
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-f98m-hcjv-7rp9
- https://www.vulncheck.com/advisories/phpmyfaq-before-2fa-brute-force-via-session-scoped-throttle
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-f98m-hcjv-7rp9
Get alerted when CVE-2026-76213 or the next vulnerability affects your stack