What’s Vulnerable › Vulnerabilities
CVE-2026-76218: GitPython before 3.1.58 Remote Code Execution via Repo.init
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-08-19 · updated 2026-09-03
- Weakness: CWE-88
Description
GitPython before 3.1.58 contains a remote code execution vulnerability in Repo.init that forwards unsafe git options without validation. Attackers can supply a template parameter pointing to a directory with malicious git hooks that execute arbitrary code when git operations are performed on the initialized repository.
Affected products
- gitpython-developers GitPython: before 3.1.58 — fixed in 3.1.58
How to fix
Upgrade to a fixed version: gitpython-developers GitPython 3.1.58. Check the vendor advisory for mitigations.
References
- https://github.com/gitpython-developers/GitPython/security/advisories/GHSA-9rj7-rf2p-w77r
- https://www.vulncheck.com/advisories/gitpython-before-remote-code-execution-via-repo-init
Get alerted when CVE-2026-76218 or the next vulnerability affects your stack