What’s Vulnerable › Vulnerabilities
CVE-2026-76223: ArcadeDB before 26.8.1 Permission Bypass via DEFINE FUNCTION
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-09-08
- Weakness: CWE-862
Description
ArcadeDB (com.arcadedb) versions 26.7.3 and earlier fail to enforce the UPDATE_SCHEMA permission check when a DEFINE FUNCTION statement targets an already-existing function library. A user with only database access can add or overwrite SQL or Cypher functions in an existing library and persist the change, enabling tampering with admin-defined function logic. The issue is fixed in 26.8.1. (JavaScript functions still trigger the UPDATE_SECURITY check and are not affected.)
Affected products
- ArcadeData arcadedb: before 26.8.1 — fixed in 26.8.1
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-rv64-62hr-wv2p
- https://www.vulncheck.com/advisories/arcadedb-before-permission-bypass-via-define-function
Get alerted when CVE-2026-76223 or the next vulnerability affects your stack