What’s Vulnerable › Vulnerabilities
CVE-2026-76224: ArcadeDB before 26.8.1 Remote Code Execution via Groovy Fallback
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-09-08
- Weakness: CWE-94
Description
ArcadeDB before 26.8.1 (arcadedb-gremlin, affected <= 26.7.3) contains a remote code execution vulnerability in its Gremlin query engine. Although the engine defaults to the documented-secure java (gremlin-lang) engine, ArcadeGremlin.executeStatement() silently falls back to the insecure Groovy engine whenever a request carries any query parameter and the query does not parse as gremlin-lang. An authenticated user with any database role, including a read-only reader, can submit a parameterized Gremlin query to trigger the Groovy fallback and execute arbitrary operating system commands as the ArcadeDB server process user.
Affected products
- ArcadeData arcadedb: before 26.8.1 — fixed in 26.8.1
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-wcm5-4wjm-9wj3
- https://www.vulncheck.com/advisories/arcadedb-before-remote-code-execution-via-groovy-fallback
Get alerted when CVE-2026-76224 or the next vulnerability affects your stack