What’s Vulnerable › Vulnerabilities

CVE-2026-76227: Renovate 42.68.1 before 42.96.3 and 43.0.0 before 43.4.4 Environment Variable Exposure

Description

Renovate versions from 42.68.1 before 42.96.3 and from 43.0.0 before 43.4.4, including the renovate/renovate Docker images, and Mend Renovate CE/EE images (renovate-ce, renovate-ee-server, renovate-ee-worker) from 13.3.0 before 13.6.0, fail to restrict environment variables to an allowlist when spawning child processes. As a result, child processes (e.g. npm install, postUpgradeTasks, postUpdateOptions) gain full access to all environment variables of the Renovate process, allowing insider or outside attackers to exfiltrate secrets accessible to the Renovate deployment.

Affected products

How to fix

Upgrade to a fixed version: mend renovate-ce 13.6.0; mend renovate-ee-server 13.6.0; mend renovate-ee-worker 13.6.0; renovatebot renovate 42.96.3, 43.4.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76227 or the next vulnerability affects your stack