What’s Vulnerable › Vulnerabilities
CVE-2026-76228: Renovate before 42.68.5 Remote Code Execution via Gradle Wrapper
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-08
- Weakness: CWE-78
Description
Renovate versions >=32.124.0 and before 42.68.5 (and Mend renovate-ce/renovate-ee before 13.3.0) contain a command injection vulnerability in Gradle Wrapper artifact handling. When Renovate processes Gradle Wrapper updates, it invokes a wrapper update command via a shell (e.g. /bin/sh -c ... ./gradlew :wrapper --gradle-distribution-url <value>). If an attacker supplies a malicious gradle-wrapper.properties whose distributionUrl contains shell command substitution syntax such as $(...), the shell evaluates it before Gradle parses the URL, resulting in arbitrary command execution in the Renovate runtime. Exploitation requires the attacker to introduce the malicious file into a repository that Renovate scans; the issue occurs even when allowScripts is disabled.
Affected products
- mend renovate-ce: before 13.3.0 — fixed in 13.3.0
- mend renovate-ee-server: before 13.3.0 — fixed in 13.3.0
- mend renovate-ee-worker: before 13.3.0 — fixed in 13.3.0
- renovatebot renovate: from 32.124.0 before 42.68.5 — fixed in 42.68.5
How to fix
Upgrade to a fixed version: mend renovate-ce 13.3.0; mend renovate-ee-server 13.3.0; mend renovate-ee-worker 13.3.0; renovatebot renovate 42.68.5. Check the vendor advisory for mitigations.
References
- https://github.com/renovatebot/renovate/security/advisories/GHSA-pfq2-hh62-7m96
- https://www.vulncheck.com/advisories/renovate-before-remote-code-execution-via-gradle-wrapper
- https://github.com/renovatebot/renovate/security/advisories/GHSA-pfq2-hh62-7m96
Get alerted when CVE-2026-76228 or the next vulnerability affects your stack