What’s Vulnerable › Vulnerabilities
CVE-2026-76254: SPL Command Safeguards Bypass through Splunk Web in Splunk Enterprise
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-08-27
- Weakness: CWE-943
Description
In Splunk Enterprise versions below 10.4.2, 10.2.6, 10.0.9, 9.4.14, and 9.3.14, an unauthenticated user could cause another user to dispatch arbitrary Search Processing Language (SPL) pipelines from Dataset Explorer with the same privileges as that user, which can allow for access to all relevant data and system integrity available to that user and affect system availability. The vulnerability is possible because Dataset Explorer does not validate or escape dataset names before building SPL searches and does not apply SPL safeguards for risky commands to those searches. The vulnerability requires the attacker to phish the user by tricking them into opening the crafted link. The unauthenticated user should not be able to exploit the vulnerability at will. For more information see Explore a dataset (https://help.splunk.com/en/splunk-enterprise/manage-knowledge-objects/knowledge-management-manual/10.4/manage-and-explore-datasets/explore-a-dataset) and SPL safeguards for risky commands (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/best-practices-for-splunk-platform-security/spl-safeguards-for-risky-commands) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.3.0 before 9.3.14; from 9.4.0 before 9.4.14; from 10.0.0 before 10.0.9; from 10.2.0 before 10.2.6; from 10.4.0 before 10.4.2 — fixed in 10.0.9, 10.2.6, 10.4.2, 9.3.14, 9.4.14
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.9, 10.2.6, 10.4.2, 9.3.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76254 or the next vulnerability affects your stack