What’s Vulnerable › Vulnerabilities

CVE-2026-76256: Information Exposure through REST API Endpoints in Splunk Secure Gateway

Description

In Splunk Enterprise versions below 10.4.2, 10.2.6, 10.0.9, and 9.4.14, and Splunk Secure Gateway versions below 3.10.9, 3.9.23, and 3.8.70, a user who does not hold the "admin" or "power" Splunk roles could read sensitive Security Assertion Markup Language setup and instance settings information through Splunk Secure Gateway Representational State Transfer (REST) API endpoints. The vulnerability is possible because the affected Security Assertion Markup Language setup and instance settings REST API endpoints do not enforce authorization requirements before returning configuration information.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 9.4.14, 10.0.9, 10.2.6, 10.4.2; Splunk Secure Gateway 3.8.70, 3.9.23, 3.10.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76256 or the next vulnerability affects your stack