What’s Vulnerable › Vulnerabilities

CVE-2026-76263: Improper Access Control through the REST API in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.4.2 and 10.2.6, a user who does not hold the "admin" or "power" Splunk roles could delete Splunk Processing Language version 2 (SPL2) modules belonging to other users through the data management orchestrator interface. The vulnerability does not affect Splunk Enterprise versions below 10.2. The broken object level authorization is possible because the data management orchestrator does not verify that the requesting user owns the target resources before it deletes the modules. For more information see Manage SPL2-based apps (https://help.splunk.com/en/splunk-enterprise/administer/admin-manual/10.4/meet-splunk-apps/manage-spl2-based-apps) in the Splunk documentation.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.2.6, 10.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76263 or the next vulnerability affects your stack