What’s Vulnerable › Vulnerabilities

CVE-2026-76264: Improper Authorization through the REST API in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.4.2, 10.2.6, 10.0.10, and 9.4.15, a user who does not hold the "admin" or "power" Splunk roles could create or edit scripted lookup definitions through raw configuration endpoints. The vulnerability is possible because raw transforms configuration write paths do not apply external lookup capability checks before saving scripted lookup settings.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.0.10, 10.2.6, 10.4.2, 9.4.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76264 or the next vulnerability affects your stack