What’s Vulnerable › Vulnerabilities

CVE-2026-76265: Improper Access Control through REST API Endpoints in Splunk Secure Gateway

Description

In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, and Splunk Secure Gateway versions below 3.10.11, 3.9.25, and 3.8.72, a user who does not hold the "admin" or "power" Splunk roles could access privileged Splunk Secure Gateway functionality. With this access, the user could cause Splunk Secure Gateway to sign attacker-controlled payloads. The vulnerability is possible because multiple Splunk Secure Gateway Representational State Transfer (REST) API endpoints do not enforce authorization requirements before processing requests.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.0.10, 10.2.7, 10.4.3, 9.4.15; Splunk Secure Gateway 3.10.11, 3.8.72, 3.9.25. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76265 or the next vulnerability affects your stack