What’s Vulnerable › Vulnerabilities

CVE-2026-76266: Local Privilege Escalation through Linux Package Upgrades in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15 on Linux, a local user who can run commands as the user account running Splunk Enterprise could cause an affected Linux package upgrade to run attacker-controlled operating-system commands with root privileges. The vulnerability is possible because the Linux package maintainer script trusts existing Splunk Enterprise installation content when it performs upgrade operations with root privileges. The vulnerability requires an affected Linux package upgrade to occur after the local user modifies the installation. The local user should not be able to elevate privileges at will.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.0.10, 10.2.7, 10.4.3, 9.4.15. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76266 or the next vulnerability affects your stack