What’s Vulnerable › Vulnerabilities
CVE-2026-76273: Improper Input Validation through the collect Command in Splunk Enterprise
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-14
- Weakness: CWE-20
Description
In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, a user that holds a role with the run_collect capability could use the collect Search Processing Language (SPL) command to add attacker-controlled content to system-level messages on the Splunk platform instance. The vulnerability is possible because the collect command does not validate the index name before processing the value. For more information see collect (https://help.splunk.com/en/splunk-enterprise/search/spl-search-reference/10.4/search-commands/collect), Define roles on the Splunk platform with capabilities (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/manage-splunk-platform-users-and-roles/define-roles-on-the-splunk-platform-with-capabilities), and System endpoint descriptions (https://help.splunk.com/en/splunk-enterprise/rest-api-reference/10.4/system-endpoints/system-endpoint-descriptions) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.15; from 10.0.0 before 10.0.10; from 10.2.0 before 10.2.7; from 10.4.0 before 10.4.3 — fixed in 10.0.10, 10.2.7, 10.4.3, 9.4.15
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.10, 10.2.7, 10.4.3, 9.4.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76273 or the next vulnerability affects your stack