What’s Vulnerable › Vulnerabilities
CVE-2026-76277: Improper Input Validation of Native Splunk Usernames through the REST API in Splunk Enterprise
- Severity: medium (CVSS 4.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-14
- Weakness: CWE-20
Description
In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, a user that holds a role with the edit_user capability could create a native Splunk username that ends with a period. The vulnerability is possible because username validation does not reject a trailing period before the username is used for a user directory. This can cause distinct native Splunk usernames to share per-user configuration data, and user-management operations can affect the wrong account or fail. For more information see Set up native Splunk authentication (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/use-the-native-splunk-platform-authentication-scheme/set-up-native-splunk-authentication) and Define roles on the Splunk platform with capabilities (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/manage-splunk-platform-users-and-roles/define-roles-on-the-splunk-platform-with-capabilities) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.15; from 10.0.0 before 10.0.10; from 10.2.0 before 10.2.7; from 10.4.0 before 10.4.3 — fixed in 10.0.10, 10.2.7, 10.4.3, 9.4.15
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.10, 10.2.7, 10.4.3, 9.4.15. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76277 or the next vulnerability affects your stack