What’s Vulnerable › Vulnerabilities
CVE-2026-76278: Authorization Bypass in SPL2 Module Permissions in Splunk Enterprise
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-14
- Weakness: CWE-639
Description
In Splunk Enterprise versions below 10.4.3, 10.2.7, and 10.0.10, a user that holds a role with the edit_spl2_module_permissions capability could use the affected Representational State Transfer (REST) API to access permission grants for SPL2 modules that the user does not have permission to view. The vulnerability is possible because Splunk Enterprise does not verify that the user can read the requested app before the affected REST API returns SPL2 module permission grants. For more information see Module permissions (https://help.splunk.com/en/splunk-enterprise/search/spl2-search-manual/modules-statements-and-views/module-permissions) and Manage SPL2 modules (https://help.splunk.com/en/splunk-enterprise/search/spl2-search-manual/multiple-searches-in-an-spl2-module/manage-spl2-modules) in the Splunk documentation. Splunk Enterprise versions 9.4.x are not affected.
Affected products
- Splunk Enterprise: from 10.0.0 before 10.0.10; from 10.2.0 before 10.2.7; from 10.4.0 before 10.4.3 — fixed in 10.0.10, 10.2.7, 10.4.3
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.10, 10.2.7, 10.4.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76278 or the next vulnerability affects your stack