What’s Vulnerable › Vulnerabilities
CVE-2026-76280: Incorrect Permission Assignment for App Key Value Store Collections in Splunk Secure Gateway
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-14
- Weakness: CWE-732
Description
In Splunk Enterprise versions below 10.4.3, 10.2.7, 10.0.10, and 9.4.15, and Splunk Secure Gateway versions below 3.10.11, 3.9.25, and 3.8.72, an authenticated user who does not hold the "admin" or "sc_admin" Splunk roles could modify Splunk Secure Gateway alert and mobile-device recipient data in App Key Value Store (KV Store) collections that later alert and subscription workflows use. The vulnerability is possible because the affected collections allow unrestricted write access instead of limiting writes to authorized Splunk Secure Gateway workflows. For more information see About the app key value store (https://help.splunk.com/en/splunk-enterprise/administer/admin-manual/10.4/administer-the-app-key-value-store/about-the-app-key-value-store), KV store endpoint descriptions (https://help.splunk.com/en/splunk-enterprise/leverage-rest-apis/rest-api-reference/10.4/kv-store-endpoints/kv-store-endpoint-descriptions), and About configuring role-based user access (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/manage-splunk-platform-users-and-roles/about-configuring-role-based-user-access) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.15; from 10.0.0 before 10.0.10; from 10.2.0 before 10.2.7; from 10.4.0 before 10.4.3 — fixed in 10.0.10, 10.2.7, 10.4.3, 9.4.15
- Splunk Secure Gateway: from 3.8.0 before 3.8.72; from 3.9.0 before 3.9.25; from 3.10.0 before 3.10.11 — fixed in 3.10.11, 3.8.72, 3.9.25
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.10, 10.2.7, 10.4.3, 9.4.15; Splunk Secure Gateway 3.10.11, 3.8.72, 3.9.25. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76280 or the next vulnerability affects your stack