What’s Vulnerable › Vulnerabilities
CVE-2026-76291: Improper Access Control through Scheduled Search Safeguards in Splunk Enterprise
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-30
- Weakness: CWE-284
Description
In Splunk Enterprise versions below 10.4.4, 10.2.8, 10.0.11, and 9.4.16, a user that holds a role with the schedule_search capability could bypass the expected safeguards in the scheduled search workflow. The user could then run risky Search Processing Language (SPL) commands that disclose or alter Splunk Enterprise data or disrupt Splunk Enterprise availability. The vulnerability is possible because the Splunk Enterprise search scheduler does not apply SPL safeguards for risky commands to scheduled searches. For more information see SPL safeguards for risky commands (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.6/best-practices-for-splunk-platform-security/spl-safeguards-for-risky-commands) in the Splunk documentation. For more information see authorize.conf (https://help.splunk.com/en/data-management/splunk-enterprise-admin-manual/10.6/configuration-file-reference/10.6.0-configuration-file-reference/authorize.conf) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.16; from 10.0.0 before 10.0.11; from 10.2.0 before 10.2.8; from 10.4.0 before 10.4.4 — fixed in 9.4.16, 10.0.11, 10.2.8, 10.4.4
- Splunk Enterprise: from 10.4 before 10.4.4; from 10.2 before 10.2.8; from 10.0 before 10.0.11; from 9.4 before 9.4.16 — fixed in 10.0.11, 10.2.8, 10.4.4, 9.4.16
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.4.16, 10.0.11, 10.2.8, 10.4.4; Splunk Enterprise 10.0.11, 10.2.8, 10.4.4, 9.4.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76291 or the next vulnerability affects your stack