What’s Vulnerable › Vulnerabilities
CVE-2026-76292: Missing Authorization through REST API Endpoints in Splunk Secure Gateway
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-30
- Weakness: CWE-862
Description
In Splunk Enterprise versions below 10.4.4, 10.2.8, 10.0.11, and 9.4.16, and Splunk Secure Gateway versions below 3.10.12, 3.9.26, and 3.8.73, a low-privileged user that does not hold the "admin" Splunk role or the "sc_admin" Splunk Secure Gateway role could read mobile alert notification data for other users through Splunk Secure Gateway App Key Value Store (KV Store) Representational State Transfer (REST) API endpoints. The vulnerability is possible because the affected Splunk Secure Gateway App Key Value Store collections do not enforce user-level authorization for read requests. For more information see About the app key value store (https://help.splunk.com/en/splunk-enterprise/administer/admin-manual/10.2/administer-the-app-key-value-store/about-the-app-key-value-store) and About configuring role-based user access (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.2/manage-splunk-platform-users-and-roles/about-configuring-role-based-user-access) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.16; from 10.0.0 before 10.0.11; from 10.2.0 before 10.2.8; from 10.4.0 before 10.4.4 — fixed in 9.4.16, 10.0.11, 10.2.8, 10.4.4
- Splunk Secure Gateway: from 3.8.0 before 3.8.73; from 3.9.0 before 3.9.26; from 3.10.0 before 3.10.12 — fixed in 3.8.73, 3.9.26, 3.10.12
- Splunk Enterprise: from 10.4 before 10.4.4; from 10.2 before 10.2.8; from 10.0 before 10.0.11; from 9.4 before 9.4.16 — fixed in 10.0.11, 10.2.8, 10.4.4, 9.4.16
- Splunk Secure Gateway: from 3.10 before 3.10.12; from 3.9 before 3.9.26; from 3.8 before 3.8.73 — fixed in 3.10.12, 3.8.73, 3.9.26
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.4.16, 10.0.11, 10.2.8, 10.4.4; Splunk Secure Gateway 3.8.73, 3.9.26, 3.10.12; Splunk Enterprise 10.0.11, 10.2.8, 10.4.4, 9.4.16; Splunk Secure Gateway 3.10.12, 3.8.73, 3.9.26. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76292 or the next vulnerability affects your stack