What’s Vulnerable › Vulnerabilities
CVE-2026-76297: Federated Search Provider State Change through Cross-Site Request Forgery (CSRF) in Splunk Web for Splunk Enterprise
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-21 · updated 2026-10-30
- Weakness: CWE-352
Description
In Splunk Enterprise versions below 10.4.4, 10.2.8, 10.0.11, and 9.4.16, an unauthenticated user could trick a user that holds a role with the edit_federated_providers capability into turning off all federated search providers. Successful exploitation could temporarily prevent federated searches from retrieving data from remote datasets. The vulnerability is possible because the federated provider Representational State Transfer (REST) API accepts GET requests for actions that change provider state. The vulnerability requires the attacker to phish the affected user by tricking them into initiating a request within their browser. The unauthenticated user should not be able to exploit the vulnerability at will. For more information see Run federated searches over remote Splunk platform deployments (https://help.splunk.com/en/splunk-enterprise/search/federated-search/10.6/run-federated-searches-across-other-splunk-deployments/run-federated-searches-over-remote-splunk-platform-deployments) and Define roles on the Splunk platform with capabilities (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/manage-splunk-platform-users-and-roles/define-roles-on-the-splunk-platform-with-capabilities) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.16; from 10.0.0 before 10.0.11; from 10.2.0 before 10.2.8; from 10.4.0 before 10.4.4 — fixed in 9.4.16, 10.0.11, 10.2.8, 10.4.4
- Splunk Enterprise: from 10.4 before 10.4.4; from 10.2 before 10.2.8; from 10.0 before 10.0.11; from 9.4 before 9.4.16 — fixed in 10.4.4, 10.2.8, 10.0.11, 9.4.16
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.4.16, 10.0.11, 10.2.8, 10.4.4; Splunk Enterprise 10.4.4, 10.2.8, 10.0.11, 9.4.16. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76297 or the next vulnerability affects your stack