What’s Vulnerable › Vulnerabilities
CVE-2026-76317: Path Traversal through the Lookup Configuration REST API in Splunk Enterprise
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-08-27
- Weakness: CWE-26
Description
In Splunk Enterprise versions below 10.4.2, 10.2.6, 10.0.9, and 9.4.14, a user who does not hold the "admin" or "power" Splunk roles could move files that the user account running Splunk Enterprise can read into a lookup that the user controls. The user could then access all relevant data and affect system integrity and availability on the search head. The vulnerability is possible because the lookup configuration endpoint does not resolve lookup source paths before checking whether they stay inside the allowed lookup staging area. For more information see About lookups (https://help.splunk.com/en/splunk-enterprise/manage-knowledge-objects/knowledge-management-manual/10.4/use-lookups-in-splunk-web/about-lookups) and Define roles on the Splunk platform with capabilities (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/manage-splunk-platform-users-and-roles/define-roles-on-the-splunk-platform-with-capabilities) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.14; from 10.0.0 before 10.0.9; from 10.2.0 before 10.2.6; from 10.4.0 before 10.4.2 — fixed in 10.0.9, 10.2.6, 10.4.2, 9.4.14
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.9, 10.2.6, 10.4.2, 9.4.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76317 or the next vulnerability affects your stack