What’s Vulnerable › Vulnerabilities
CVE-2026-76319: Remote Code Execution (RCE) through Federated Search in Splunk Enterprise
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-08-27
- Weakness: CWE-862
Description
In Splunk Enterprise versions below 10.4.2, 10.2.6, 10.0.9, and 9.4.14, a low-privileged user that does not hold the fsh_manage capability could perform Remote Code Execution through Federated Search bundle selection. This could allow for access to all relevant data and affect system integrity and availability. The vulnerability is possible because the Federated Search dispatch flow accepts caller-controlled bundle selection without enforcing the capability that manages federated providers and indexes. For more information see Security models for Federated Search for Splunk (https://help.splunk.com/en/splunk-enterprise/search/federated-search/10.4/run-federated-searches-across-other-splunk-deployments/service-accounts-and-security-for-federated-search-for-splunk/security-models-for-federated-search-for-splunk) and Define roles on the Splunk platform with capabilities (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/manage-splunk-platform-users-and-roles/define-roles-on-the-splunk-platform-with-capabilities) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.14; from 10.0.0 before 10.0.9; from 10.2.0 before 10.2.6; from 10.4.0 before 10.4.2 — fixed in 10.0.9, 10.2.6, 10.4.2, 9.4.14
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.9, 10.2.6, 10.4.2, 9.4.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76319 or the next vulnerability affects your stack