What’s Vulnerable › Vulnerabilities

CVE-2026-76325: Stored Cross-Site Scripting (XSS) through Splunk Web in Splunk Enterprise

Description

In Splunk Enterprise versions below 10.4.2, 10.2.6, 10.0.9, and 9.4.14, a user who holds the "power" Splunk role could store a malicious ui-tour knowledge object that matches an auto-tour page name and share the object at the app level. The object can execute arbitrary JavaScript in the browser of another authenticated user who visits a standard Splunk Web page. The JavaScript could expose all relevant data and affect system integrity within the second user permissions. The Cross-Site Scripting (XSS) vulnerability is possible because Splunk Web resolves auto-tour entries from the app namespace and uses untrusted tour content when building the tour image.

Affected products

How to fix

Upgrade to a fixed version: Splunk Enterprise 10.0.9, 10.2.6, 10.4.2, 9.4.14. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76325 or the next vulnerability affects your stack