What’s Vulnerable › Vulnerabilities
CVE-2026-76327: SPL Injection through Splunk Web in Splunk Secure Gateway
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-27
- Weakness: CWE-943
Description
In Splunk Enterprise versions below 10.4.2, 10.2.6, 10.0.9, and 9.4.14, and Splunk Secure Gateway versions below 3.10.9, 3.9.23, and 3.8.70, an unauthenticated user could trick a user who holds the "admin" or "sc_admin" Splunk roles into opening a crafted Splunk Web Uniform Resource Locator (URL). The resulting dashboard searches could run arbitrary Search Processing Language (SPL) commands with the permissions available to the affected user. The commands could expose all relevant data available to that user and affect search results or lookup data. The vulnerability is possible because Splunk Secure Gateway dashboards do not correctly neutralize caller-supplied values before using them in dashboard searches. The vulnerability requires the attacker to phish the affected user by tricking them into initiating a request within their browser. The unauthenticated user should not be able to exploit the vulnerability at will.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.14; from 10.0.0 before 10.0.9; from 10.2.0 before 10.2.6; from 10.4.0 before 10.4.2 — fixed in 9.4.14, 10.0.9, 10.2.6, 10.4.2
- Splunk Secure Gateway: from 3.8.0 before 3.8.70; from 3.9.0 before 3.9.23; from 3.10.0 before 3.10.9 — fixed in 3.8.70, 3.9.23, 3.10.9
How to fix
Upgrade to a fixed version: Splunk Enterprise 9.4.14, 10.0.9, 10.2.6, 10.4.2; Splunk Secure Gateway 3.8.70, 3.9.23, 3.10.9. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76327 or the next vulnerability affects your stack