What’s Vulnerable › Vulnerabilities
CVE-2026-76336: Improper Access Control through the REST API in Splunk Enterprise
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-08-26
- Weakness: CWE-862
Description
In Splunk Enterprise versions below 10.4.2 and 10.2.6, a user who does not hold the "admin" or "power" Splunk roles could delete all Search Processing Language 2 (SPL2) modules across all apps and users on the instance through the SPL2 module management Representational State Transfer (REST) API. This could delete exported datasets and functions, affect system integrity, and cause partial service disruption. The vulnerability does not affect Splunk Enterprise versions below 10.2. The vulnerability is possible because the SPL2 module management REST API does not sufficiently authorize and validate module deletion requests. For more information see Manage SPL2 modules (https://help.splunk.com/en/splunk-enterprise/search/spl2-search-manual/multiple-searches-in-an-spl2-module/manage-spl2-modules) and Module permissions (https://help.splunk.com/en/splunk-enterprise/search/spl2-search-manual/modules-statements-and-views/module-permissions) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 10.2.0 before 10.2.6; from 10.4.0 before 10.4.2 — fixed in 10.2.6, 10.4.2
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.2.6, 10.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76336 or the next vulnerability affects your stack