What’s Vulnerable › Vulnerabilities
CVE-2026-76341: Risky Commands Safeguards Bypass through Table Editor Dataset Initial Data in Splunk Enterprise
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-08-26
- Weakness: CWE-863
Description
In Splunk Enterprise versions below 10.4.2, 10.2.6, 10.0.9, and 9.4.14, a user who holds the "power" Splunk role could store attacker-controlled Search Processing Language (SPL) in a Table Editor dataset and share the dataset. A user who holds the "admin" Splunk role triggers the SPL when that user opens the dataset in the Table Editor. The SPL runs using the permissions of the second user and could expose all relevant data and modify limited data on the search head. The vulnerability is possible because the Table Editor does not apply SPL safeguards for risky commands when it prepares the dataset initial data. The vulnerability requires the attacker to phish the affected user by tricking them into initiating a request within their browser. The user who holds the "power" Splunk role should not be able to exploit the vulnerability at will. For more information see Define initial data for a new table dataset (https://help.splunk.com/en/splunk-enterprise/manage-knowledge-objects/knowledge-management-manual/9.4/create-and-edit-table-datasets/define-initial-data-for-a-new-table-dataset), SPL safeguards for risky commands (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.2/best-practices-for-splunk-platform-security/spl-safeguards-for-risky-commands), and Define roles on the Splunk platform with capabilities (https://help.splunk.com/en/splunk-enterprise/administer/manage-users-and-security/10.4/manage-splunk-platform-users-and-roles/define-roles-on-the-splunk-platform-with-capabilities) in the Splunk documentation.
Affected products
- Splunk Enterprise: from 9.4.0 before 9.4.14; from 10.0.0 before 10.0.9; from 10.2.0 before 10.2.6; from 10.4.0 before 10.4.2 — fixed in 10.0.9, 10.2.6, 10.4.2, 9.4.14
How to fix
Upgrade to a fixed version: Splunk Enterprise 10.0.9, 10.2.6, 10.4.2, 9.4.14. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76341 or the next vulnerability affects your stack