What’s Vulnerable › Vulnerabilities
CVE-2026-76451: Cisco Identity Services Engine Certificate Management SQL Injection Vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-28
- Weakness: CWE-564
Description
A vulnerability in Cisco Identity Services Engine (ISE) and Cisco ISE Passive Identity Connector (ISE-PIC) could allow an authenticated, remote attacker to conduct an SQL or HQL injection attack on an affected device. This vulnerability is due to insufficient validation of user-supplied input to the affected APIs before it is used to build database queries. An attacker could exploit this vulnerability by sending a crafted request to an affected device. A successful exploit could allow the attacker to execute arbitrary SQL or HQL queries against the underlying database, which could allow the attacker to view or modify data that they are not authorized to access. To exploit this vulnerability, the attacker must have valid administrative credentials.
Affected products
- Cisco Identity Services Engine: from 3.1.0 before 3.3.0; 3.3.0-patch1, 3.3.0-patch10, 3.3.0-patch11, 3.3.0-patch2, 3.3.0-patch3, 3.3.0-patch4 (+16) — fixed in 3.3.0
- Cisco Identity Services Engine Passive Identity Connector: from 3.1.0 before 3.3.0; 3.3.0-patch1, 3.3.0-patch10, 3.3.0-patch11, 3.3.0-patch2, 3.3.0-patch3, 3.3.0-patch4 (+12) — fixed in 3.3.0
How to fix
Upgrade to a fixed version: Cisco Identity Services Engine 3.3.0; Cisco Identity Services Engine Passive Identity Connector 3.3.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76451 or the next vulnerability affects your stack