What’s Vulnerable › Vulnerabilities
CVE-2026-76614: OpenEMR < 8.3.0 Path Traversal Information Disclosure via EDI Archive Restore
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-19 · updated 2026-10-27
- Weakness: CWE-22
Description
OpenEMR before 8.3.0 contains a path traversal vulnerability in the EDI archive restore function. The archrestore_sel POST parameter is passed to the archive restore handler without sanitization for path traversal sequences. The handler checks whether the supplied path exists on the filesystem, and the differing response messages leak whether the target path exists. An authenticated user with EOB Data Entry permissions can probe arbitrary filesystem paths on the server to determine file existence.
Affected products
- openemr: before 8.3.0 — fixed in 8.3.0
How to fix
Upgrade to a fixed version: openemr 8.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/openemr/openemr/commit/7973cab3fe3f2fd2374ed71c02605e3c93491c36
- https://github.com/openemr/openemr/releases/tag/v8_3_0
- https://github.com/openemr/openemr/security/advisories/GHSA-gfwc-jg5p-jcp4
- https://www.vulncheck.com/advisories/openemr-path-traversal-information-disclosure-via-edi-archive-restore
- https://github.com/openemr/openemr/security/advisories/GHSA-gfwc-jg5p-jcp4
Get alerted when CVE-2026-76614 or the next vulnerability affects your stack