What’s Vulnerable › Vulnerabilities

CVE-2026-76642: util-linux libmount Privilege Escalation via Failed Mount Helper

Description

util-linux versions through 2.41.5 and 2.42.2 fail to check mount helper exit status before running post-mount hooks, allowing unprivileged users to execute privileged operations on pre-existing filesystems. Attackers can exploit X-mount.idmap or X-mount.owner hooks to clone filesystems with inherited suid bits or modify target inode permissions after a helper fails, achieving privilege escalation.

Affected products

How to fix

Upgrade to a fixed version: util-linux 2.41.6, 2.42.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76642 or the next vulnerability affects your stack