What’s Vulnerable › Vulnerabilities
CVE-2026-76646: Apache MyFaces: Denial of Service via Unbounded Request Parsing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-17
- Weakness: CWE-400
Description
A remote attacker could cause excessive resource consumption by supplying specially crafted request parameters, potentially resulting in a denial of service condition. Older unsupported versions may also be affected. Users are recommended to upgrade to versions 2.3.12, 2.3-next-M9, 3.0.4, 4.0.4, or 4.1.4, which fix this issue.
Affected products
- Apache Software Foundation Apache MyFaces: from 2.2.0-beta through 2.2.15; from 2.3-next-M1 through 2.3-next-M8; from 2.3.1 through 2.3.11; from 3.0.0 through 3.0.3; from 4.0.0 through 4.0.3; from 4.1.0 through 4.1.3
References
- https://lists.apache.org/thread/q8zxrdhbmmx8ofgr9s7ymnqo8l2x8oy9
- http://www.openwall.com/lists/oss-security/2026/09/16/12
Get alerted when CVE-2026-76646 or the next vulnerability affects your stack