What’s Vulnerable › Vulnerabilities
CVE-2026-76651: Pre-Authentication Multipart Boundary Buffer Overflow in HTTP Service in TP-Link TL-WR841N
- Severity: medium (CVSS 5.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-01
- Weakness: CWE-120
Description
A buffer overflow vulnerability exists in the embedded HTTP service in TL-WR841N v14 when processing multipart/form-data requests. Insufficient validation of an attacker-controlled boundary parameter may allow a remote unauthenticated attacker to submit a crafted request that corrupts memory by overwriting data beyond the bounds of an internal buffer. Successful exploitation may result in modification or corruption of process memory, potentially leading to undefined application behavior. Arbitrary code execution, information disclosure, and denial-of-service conditions have not been demonstrated.
Affected products
- TP-Link System Inc. TL-WR841N v14: before TL-WR841N(US)_V14_4.19 Build 260820 Rel.33478; before TL-WR841N(EU)_V14_4.19 Build 260821 Rel.56588 — fixed in TL-WR841N(EU)_V14_4.19 Build 260821 Rel.56588, TL-WR841N(US)_V14_4.19 Build 260820 Rel.33478
How to fix
Upgrade to a fixed version: TP-Link System Inc. TL-WR841N v14 TL-WR841N(EU)_V14_4.19 Build 260821 Rel.56588, TL-WR841N(US)_V14_4.19 Build 260820 Rel.33478. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/tl-wr841n/v14/#Firmware
- https://www.tp-link.com/us/support/download/tl-wr841n/v14/#Firmware
- https://www.tp-link.com/us/support/faq/5270/
Get alerted when CVE-2026-76651 or the next vulnerability affects your stack