What’s Vulnerable › Vulnerabilities
CVE-2026-76652: Authenticated Directory Traversal Vulnerability in File Upload Functionality in TP-Link TL-MR6400 and Archer MR600
- Severity: medium (CVSS 4.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-10 · updated 2026-09-11
- Weakness: CWE-22
Description
An authenticated directory traversal vulnerability in file upload functionality has been identified in Archer MR600 (v2, v3 & v5) and TL-MR6400 v8. Due to insufficient validation of user-supplied file information, an authenticated remote attacker with access to the affected upload functionality could upload a specially crafted file and cause it to be written outside the intended directory. Successful exploitation could allow an authenticated remote attacker to write files to unintended locations, potentially overwriting or modifying files accessible to the affected service; arbitrary code execution has not been demonstrated.
Affected products
- TP-Link Systems Inc. Archer MR600: from v3 before MR600(EU)_V3_1.4.0 Build 260827; from v5 before MR600(EU)_V5_1.9.0 Build 260805; from v2 before MR600(EU)_V2_1.12.0 Build 2600826 — fixed in MR600(EU)_V2_1.12.0 Build 2600826, MR600(EU)_V3_1.4.0 Build 260827, MR600(EU)_V5_1.9.0 Build 260805
- TP-Link Systems Inc. TL-MR6400 v8: before 1.5.0 0.9.1 v0001.0 Build 260610 Rel.67978n — fixed in 1.5.0 0.9.1 v0001.0 Build 260610 Rel.67978n
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Archer MR600 MR600(EU)_V2_1.12.0 Build 2600826, MR600(EU)_V3_1.4.0 Build 260827, MR600(EU)_V5_1.9.0 Build 260805; TP-Link Systems Inc. TL-MR6400 v8 1.5.0 0.9.1 v0001.0 Build 260610 Rel.67978n. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/archer-mr600/v5/#Firmware
- https://www.tp-link.com/en/support/download/tl-mr6400/v8/#Firmware
- https://www.tp-link.com/us/support/faq/5292/
Get alerted when CVE-2026-76652 or the next vulnerability affects your stack