What’s Vulnerable › Vulnerabilities
CVE-2026-76846: Grav before 2.0.16 Information Disclosure via Twig Sandbox
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-25 · updated 2026-10-12
- Weakness: CWE-522
Description
Grav before 2.0.16 contains an incomplete default denylist in the Twig sandbox configuration that fails to block access to system configuration secrets. Attackers with page-edit permission can use config.get() or config.toArray() in Twig templates to retrieve sensitive values like system.cache.redis.password when config_access is enabled.
Affected products
- getgrav grav: before 2.0.16 — fixed in 2.0.16
How to fix
Upgrade to a fixed version: getgrav grav 2.0.16. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/security/advisories/GHSA-xjw5-q542-3vmr
- https://www.vulncheck.com/advisories/grav-before-information-disclosure-via-twig-sandbox
- https://github.com/getgrav/grav/security/advisories/GHSA-xjw5-q542-3vmr
Get alerted when CVE-2026-76846 or the next vulnerability affects your stack