What’s Vulnerable › Vulnerabilities
CVE-2026-76851: Server-Side Request Forgery vulnerability in GitHub Enterprise Server allowed remote code execution via network access from pre-receive hooks to internal services
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-01 · updated 2026-09-08
- Weakness: CWE-918
Description
A Server-Side Request Forgery (SSRF) vulnerability was identified in GitHub Enterprise Server that allowed remote code execution on the instance. Insufficient network isolation allowed malicious pre-receive hook code to impersonate an internal service and redirect trusted internal requests to a privileged service, leading to elevated code execution. Exploitation required pre-receive hook networking to be enabled and either site administrator privileges or write access to a repository containing a configured pre-receive hook. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.22 and was fixed in versions 3.17.20, 3.18.14, 3.19.11, 3.20.7, and 3.21.5. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: before 3.17.20; from 3.18.0 before 3.18.14; from 3.19.0 before 3.19.11; from 3.20.0 before 3.20.7; from 3.21.0 before 3.21.5 — fixed in 3.17.20, 3.18.14, 3.19.11, 3.20.7, 3.21.5
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.17.20, 3.18.14, 3.19.11, 3.20.7. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.17/admin/release-notes#3.17.20
- https://docs.github.com/en/enterprise-server@3.18/admin/release-notes#3.18.14
- https://docs.github.com/en/enterprise-server@3.19/admin/release-notes#3.19.11
- https://docs.github.com/en/enterprise-server@3.20/admin/release-notes#3.20.7
- https://docs.github.com/en/enterprise-server@3.21/admin/release-notes#3.21.5
Get alerted when CVE-2026-76851 or the next vulnerability affects your stack