What’s Vulnerable › Vulnerabilities

CVE-2026-76956

Description

In libexpat 2.8.2 and 2.8.3 before 2.8.4, misinterpretation of getentropy's return code leads to insufficient entropy, which results in being vulnerable to hash flooding attacks, causing a denial of service via crafted XML content.

Affected products

How to fix

Upgrade to a fixed version: libexpat project libexpat 2.8.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-76956 or the next vulnerability affects your stack