What’s Vulnerable › Vulnerabilities
CVE-2026-76957
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-09-08
- Weakness: CWE-416
Description
libexpat before 2.8.4 lacks handler call depth tracking with custom encoding callbacks. Thus, a use-after-free can occur. NOTE: this is similar to CVE-2026-50219, CVE-2026-56131 and CVE-2026-56412.
Affected products
- libexpat project libexpat: before 2.8.4 — fixed in 2.8.4
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.8.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-76957 or the next vulnerability affects your stack