What’s Vulnerable › Vulnerabilities

CVE-2026-77050: Potential denial-of-service vulnerability in get_supported_language_variant()

Description

An issue was discovered in Django 6.1 before 6.1.2, 6.0 before 6.0.9, and 5.2 before 5.2.18. `django.utils.translation.get_supported_language_variant()` is subject to a potential denial-of-service attack when processing many distinct, very long language codes, which are retained as keys in an in-memory cache and consume process memory. Earlier, unsupported Django series (such as 5.1.x, 5.0.x, and 4.2.x) were not evaluated and may also be affected. Django would like to thank Gleb Lizunov for reporting this issue.

Affected products

How to fix

Upgrade to a fixed version: Django 5.2.18, 6.0.9, 6.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-77050 or the next vulnerability affects your stack