What’s Vulnerable › Vulnerabilities
CVE-2026-77076: n8n before 1.123.69 Credential Leak via GraphQL Node Error
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-20 · updated 2026-09-01
- Weakness: CWE-209
Description
n8n versions before 1.123.69, 2.33.4, and 2.34.1 contain an information disclosure vulnerability in the GraphQL node. When a GraphQL request fails at the connection level, the node re-throws the underlying HTTP client error unchanged instead of wrapping it in n8n's standard error type. That error contains the live request's headers, including a decrypted credential secret, which the execution engine persists verbatim. Any authenticated user able to read the resulting execution can retrieve the decrypted credential secret from the stored run data.
Affected products
- n8n-io n8n: before 1.123.69; from 2.33.0 before 2.33.4; 2.34.0 — fixed in 1.123.69, 2.33.4
How to fix
Upgrade to a fixed version: n8n-io n8n 1.123.69, 2.33.4. Check the vendor advisory for mitigations.
References
- https://github.com/n8n-io/n8n/security/advisories/GHSA-9fqj-7wc5-cwhx
- https://www.vulncheck.com/advisories/n8n-before-credential-leak-via-graphql-node-error
Get alerted when CVE-2026-77076 or the next vulnerability affects your stack