What’s Vulnerable › Vulnerabilities
CVE-2026-77078: multer vulnerable to Denial of Service via crafted multipart field names
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-28 · updated 2026-09-02
- Weakness: CWE-248
Description
multer is a middleware for handling multipart/form-data in Node.js. A small multipart request containing two specially crafted text field names can cause an uncaught RangeError (Invalid array length) that terminates the Node.js process. The first field uses a very large numeric array index to allocate a maximum-length sparse array, and a second field then pushes past that length, which throws inside the append-field dependency and is not caught by multer. All versions before 2.3.0 are affected, and the issue is a remotely triggerable denial of service. The issue is fixed in multer 2.3.0. Upgrade to multer 2.3.0 to remediate.
Affected products
- multer: before 2.3.0 — fixed in 2.3.0
How to fix
Upgrade to a fixed version: multer 2.3.0. Check the vendor advisory for mitigations.
References
- https://cna.openjsf.org/security-advisories.html
- https://github.com/expressjs/multer/security/advisories/GHSA-wc9g-mqfw-jrwm
Get alerted when CVE-2026-77078 or the next vulnerability affects your stack