What’s Vulnerable › Vulnerabilities

CVE-2026-77081: n8n before 1.123.69 Allowed-Domains Bypass via GraphQL Node

Description

n8n before 1.123.69, 2.x before 2.33.4, and 2.x before 2.34.1 contain an allowed-domains bypass in the GraphQL node. When the node's Authentication parameter is set to expression mode, every authentication-gated credential selector is treated as active; if two credentials of different types are attached, the node enforces the allowed-domains policy of only the first credential while still attaching material from both. An authenticated user with workflow-authoring rights can thereby send a domain-restricted credential to an attacker-controlled endpoint, exfiltrating it with the leaked credential's permissions.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.69, 2.33.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-77081 or the next vulnerability affects your stack