What’s Vulnerable › Vulnerabilities

CVE-2026-77084: n8n before 1.123.69 Remote Code Execution via Git Node Configuration Values

Description

n8n before 1.123.69 (and 2.x before 2.33.4 / 2.34.1) contains a code execution vulnerability in the Git node. The Git node executed certain repository-local git configuration values without neutralizing them, so any subsequent Git node operation against a repository containing a malicious value would execute it as the n8n process user. This is not reachable through the Git node's own configuration controls and requires a separate file-write vulnerability elsewhere to plant the malicious value.

Affected products

How to fix

Upgrade to a fixed version: n8n-io n8n 1.123.69, 2.33.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-77084 or the next vulnerability affects your stack