What’s Vulnerable › Vulnerabilities
CVE-2026-77110: Adobe Commerce | Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') (CWE-22)
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-08 · updated 2026-09-10
- Weakness: CWE-22
Description
Adobe Commerce is affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could result in a Security feature bypass. An attacker with high privileges could leverage this vulnerability to access unauthorized files or directories outside the intended restrictions, causing a limited disruption to availability. Exploitation of this issue does not require user interaction. Scope is changed.
Affected products
- Adobe Commerce: before 2.4.4; 2.4.4, 2.4.4-p1, 2.4.4-p10, 2.4.4-p11, 2.4.4-p12, 2.4.4-p13 (+70) — fixed in 2.4.4
- Adobe Commerce: before 1.3.3; 1.3.3, 1.3.3-p1, 1.3.3-p10, 1.3.3-p11, 1.3.3-p12, 1.3.3-p13 (+49) — fixed in 1.3.3
- Adobe Magento: through 2.4.6; 2.4.7, 2.4.7-b1, 2.4.7-b2, 2.4.7-beta3, 2.4.7-p1, 2.4.7-p10 (+17)
- Adobe Commerce: through 2.4.9-2026-aug, 2.4.8-2026-aug, 2.4.7-2026-aug, 2.4.6-2026-aug, 2.4.5-2026-aug, 2.4.4-2026-aug
- Adobe Commerce: through 1.5.3-2026-aug, 1.5.2-2026-aug, 1.4.2-2026-aug, 1.3.4-2026-aug, 1.3.3-2026-aug
- Adobe Magento Open Source: through 2.4.9-2026-aug, 2.4.8-2026-aug, 2.4.7-2026-aug, 2.4.6-2026-aug
How to fix
Upgrade to a fixed version: Adobe Commerce 2.4.4; Adobe Commerce 1.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-77110 or the next vulnerability affects your stack