What’s Vulnerable › Vulnerabilities
CVE-2026-77180: NGINX Ingress Controller vulnerability
- Severity: high (CVSS 8.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-02 · updated 2026-09-03
- Weakness: CWE-76
Description
When NGINX Ingress Controller is configured with Ingress annotations, an injection vulnerability exists in the configuration generator of NGINX Ingress Controller. Multiple user-controllable fields are written into the generated NGINX configuration without sanitization. An authenticated attacker with permission to create or modify these annotations may craft values that inject arbitrary NGINX configuration directives. Impact: An authenticated attacker granted write access to NGINX Ingress Controller Ingress annotations through the Kubernetes API may be able to inject arbitrary NGINX configuration directives, create or delete files, or disable services. There is no data plane exposure; this is a control plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Ingress Controller: from 5.0.0 before 5.6.0; from 2026-lts-r1 before 2026-lts-r5 — fixed in 2026-lts-r5, 5.6.0
How to fix
Upgrade to a fixed version: F5 NGINX Ingress Controller 2026-lts-r5, 5.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-77180 or the next vulnerability affects your stack