What’s Vulnerable › Vulnerabilities
CVE-2026-77219: GNU Emacs < 31.0.91 Heap Over-Read via PBM/PPM/PGM Image Loader
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-21 · updated 2026-10-12
- Weakness: CWE-125
Description
GNU Emacs before 31.0.91 contains an integer overflow in the PBM/PPM/PGM image loader that allows an attacker to leak heap memory contents by supplying a crafted image with large dimensions and an elevated max color index. The image loader multiplies image dimensions and channel count using signed integer arithmetic; for sufficiently large values, the result wraps to a negative number, bypassing the bounds check and causing the pixel reader to access heap memory past the end of the allocated buffer. The over-read contents are interpreted as pixel color values and rendered on screen.
Affected products
- GNU Emacs: before 31.0.91 — fixed in 31.0.91
How to fix
Upgrade to a fixed version: GNU Emacs 31.0.91. Check the vendor advisory for mitigations.
References
- https://debbugs.gnu.org/cgi/bugreport.cgi?bug=81344
- https://github.com/emacs-mirror/emacs/commit/b07e634e4cf45162ae0178e32092b040587f2c6c
- https://github.com/emacs-mirror/emacs/releases/tag/emacs-31.0.91
- https://www.vulncheck.com/advisories/gnu-emacs-heap-over-read-via-pbm-ppm-pgm-image-loader
Get alerted when CVE-2026-77219 or the next vulnerability affects your stack