What’s Vulnerable › Vulnerabilities
CVE-2026-77281: Caddy: rewrite placeholder re-expansion
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-24
- Weakness: CWE-94
Description
Caddy is an extensible server platform that uses TLS by default. In version 2.11.3 and earlier, three configuration-dependent weaknesses affect the handler and placeholder layer. In modules/caddyhttp/rewrite/rewrite.go, Rewrite.Rewrite() can pass attacker-controlled replacement bytes through buildQueryString for a second placeholder expansion when a rewrite URI ends with a literal question mark, allowing injected environment or request-variable placeholders to disclose data and, when the file provider is registered, allowing injected file placeholders to disclose readable files. The issue is fixed in version 2.11.4.
Affected products
- caddyserver caddy: before 2.11.4
References
- https://github.com/caddyserver/caddy/commit/176b043b0104cee3f894023cd5a598ac29e404bb
- https://github.com/caddyserver/caddy/pull/7761
- https://github.com/caddyserver/caddy/releases/tag/v2.11.4
- https://github.com/caddyserver/caddy/security/advisories/GHSA-j8px-rmrx-76h9
Get alerted when CVE-2026-77281 or the next vulnerability affects your stack