What’s Vulnerable › Vulnerabilities
CVE-2026-7734: osrg GoBGP SRv6 L3 Service prefix_sid.go SRv6L3ServiceAttribute.DecodeFromBytes denial of service
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-404
Description
A vulnerability has been found in osrg GoBGP up to 4.3.0. This impacts the function SRv6L3ServiceAttribute.DecodeFromBytes of the file pkg/packet/bgp/prefix_sid.go of the component SRv6 L3 Service. Such manipulation of the argument data leads to denial of service. The attack may be performed from remote. Upgrading to version 4.4.0 will fix this issue. The name of the patch is f9f7b55ec258e514be0264871fa645a2c3edad11. You should upgrade the affected component.
Affected products
- osrg GoBGP: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: osrg GoBGP 4.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/osrg/gobgp/
- https://github.com/osrg/gobgp/commit/f9f7b55ec258e514be0264871fa645a2c3edad11
- https://github.com/osrg/gobgp/releases/tag/v4.4.0
- https://vuldb.com/submit/807581
- https://vuldb.com/vuln/360909
- https://vuldb.com/vuln/360909/cti
Get alerted when CVE-2026-7734 or the next vulnerability affects your stack