What’s Vulnerable › Vulnerabilities
CVE-2026-7735: osrg GoBGP AIGP Attribute bgp.go PathAttributeAigp.DecodeFromBytes buffer overflow
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-04 · updated 2026-10-26
- Weakness: CWE-119
Description
A vulnerability was found in osrg GoBGP up to 4.3.0. Affected is the function PathAttributeAigp.DecodeFromBytes of the file pkg/packet/bgp/bgp.go of the component AIGP Attribute Parser. Performing a manipulation results in buffer overflow. It is possible to initiate the attack remotely. Upgrading to version 4.4.0 is able to address this issue. The patch is named 51ad1ada06cb41ce47b7066799981816f50b7ced. The affected component should be upgraded.
Affected products
- osrg GoBGP: before 4.4.0 — fixed in 4.4.0
How to fix
Upgrade to a fixed version: osrg GoBGP 4.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/osrg/gobgp/
- https://github.com/osrg/gobgp/commit/51ad1ada06cb41ce47b7066799981816f50b7ced
- https://github.com/osrg/gobgp/releases/tag/v4.4.0
- https://vuldb.com/submit/807600
- https://vuldb.com/vuln/360910
- https://vuldb.com/vuln/360910/cti
Get alerted when CVE-2026-7735 or the next vulnerability affects your stack