What’s Vulnerable › Vulnerabilities
CVE-2026-77405: RabbitMQ amqp091-go: Missing Explicit TLS Minimum Version Configuration In URI Parser
- Severity: critical (CVSS 9.4 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-24
- Weakness: CWE-326
Description
RabbitMQ amqp091-go is a Go AMQP 0.9.1 client. Prior to 1.13.0, tlsConfigFromURI in uri.go creates tls.Config values without setting MinVersion to tls.VersionTLS12. Builds using a Go runtime whose default permits TLS 1.0 or TLS 1.1 can therefore negotiate an obsolete protocol version when connecting through an amqps URI. A network attacker able to influence TLS negotiation with such a legacy build may weaken transport protection for AMQP messages and credentials. This issue is fixed in version 1.13.0.
Affected products
- rabbitmq amqp091-go: before 1.13.0
References
- https://github.com/rabbitmq/amqp091-go/commit/c9fd433ecac2e557919e51acc9d809390c402c6e
- https://github.com/rabbitmq/amqp091-go/pull/355
- https://github.com/rabbitmq/amqp091-go/releases/tag/v1.13.0
- https://github.com/rabbitmq/amqp091-go/security/advisories/GHSA-33mj-cw25-m34h
Get alerted when CVE-2026-77405 or the next vulnerability affects your stack